Error list for GetVariable B51 (necessary get in case of eKasa error "-3")
List of speciffic errors PPeKK (the first parrameter of the get B51)
Code | Description | Enum |
|---|---|---|
1 | an instance with a different database has already been created | ERROR_CODE_EKASA_INSTALLED_WITH_OTHER_DATABASE |
2 | failed to initialize database | ERROR_CODE_EKASA_ERROR_INITIALIZE_DATABASE |
3 | failed to initialize protected data storage | ERROR_CODE_EKASA_ERROR_INITIALIZE_CHDU |
4 | failed to initialize printer | ERROR_CODE_EKASA_ERROR_INITIALIZE_PRINTER |
5 | attempt to process an unsupported message | ERROR_CODE_EKASA_ERROR_UNSUPPORTED_MESSAGE |
6 | communication with PPEKK for different UUID (attempt to hack the system) | ERROR_CODE_EKASA_ERROR_UUID_ERROR |
7 | cannot connect to protected data storage | ERROR_CODE_EKASA_ERROR_CONNECTION_CHDU |
8 | no data was found on protected data storage | ERROR_CODE_EKASA_ERROR_CHDU_NO_DATA |
9 | the data on the protected data storage is in wrong format | ERROR_CODE_EKASA_ERROR_CHDU_ERROR_DATA |
10 | protected data storage is not configured | ERROR_CODE_EKASA_ERROR_CHDU_NO_CONFIG |
11 | error while working with the database | ERROR_CODE_EKASA_ERROR_DATABASE |
12 | work with the database cannot be encrypted | ERROR_CODE_EKASA_ERROR_DATABASE_ENCRYPTION |
13 | error while generating print | ERROR_CODE_EKASA_ERROR_PRINT_GENER |
14 | parameter length error | ERROR_CODE_EKASA_ERROR_PARAM_LENGTH |
15 | if I try to write a configuration parameter that does not exist, or its value is wrong | ERROR_CODE_EKASA_ERROR_BAD_SETUP_PARAMETER |
16 | unsupported sequence | ERROR_CODE_EKASA_ERROR_UNSUPPORTED_ESC |
17 | invalid VAT rate | ERROR_CODE_EKASA_ERROR_BAD_VAT |
18 | incorrectly calculated VAT values for the receipt | ERROR_CODE_EKASA_ERROR_BAD_TOTAL_PARAGON |
19 | error in the communication module on SFS | ERROR_CODE_EKASA_ERROR_SFS_ERROR |
20 | SFS returned message sent error | ERROR_CODE_EKASA_ERROR_SFS_ERROR_RESPONSE |
21 | error when working with CFG | ERROR_CODE_EKASA_ERROR_CFG |
22 | authentification data is not uploaded | ERROR_CODE_EKASA_ERROR_NO_AUTHENTIFICATION_DATA |
23 | printer is not ready | ERROR_CODE_EKASA_ERROR_PRINTER_NOT_READY |
24 | internal error while processing the application | ERROR_CODE_EKASA_ERROR_INTERNAL |
25 | wrong quantity entered | ERROR_CODE_EKASA_ERROR_BAD_QUANTITY |
26 | wrong JC entered | ERROR_CODE_EKASA_ERROR_BAD_UNIT_PRICE |
27 | wrong amount per item entered | ERROR_CODE_EKASA_ERROR_BAD_PRICE |
28 | incorrect identification data | ERROR_CODE_EKASA_ERROR_NO_IDENTITY_DATA |
29 | incorrect authentification password | ERROR_CODE_EKASA_ERROR_NO_AUTHENTIFICATION_PASSWORD |
30 | there are multiple VAT categories for one rate | ERROR_CODE_EKASA_ERROR_VAT_DUPLICITY |
31 | data on protected data storage and PPEKK are different | ERROR_CODE_EKASA_ERROR_PPEKK_CHDU_MISMATCH |
32 | wrong authentification data format | ERROR_CODE_EKASA_ERROR_AUTHENTICATION_BAD_FORMAT |
33 | invalid authentification data certificate | ERROR_CODE_EKASA_ERROR_AUTHENTICATION_EXPIRED |
34 | TIN, DKP are not suitable for this protected data storage | ERROR_CODE_EKASA_ERROR_AUTHENTICATION_DIC_DKP |
35 | wrong identification data format | ERROR_CODE_EKASA_ERROR_IDENTITY_BAD_FORMAT |
36 | TIN, DKP are not suitable for this protected data storage | ERROR_CODE_EKASA_ERROR_IDENTITY_DIC_DKP |
37 | error while pairing corrected and broken transaction | ERROR_CODE_EKASA_ERROR_PPEKK_NEED_CORRECTION |
38 | misuse of payment by JUP | ERROR_CODE_EKASA_ERROR_BAD_JUP |
39 | poorly generated SW ID | ERROR_CODE_EKASA_ERROR_SWID |
40 | PPEKK does not have a licence | ERROR_CODE_EKASA_ERROR_LICENSE |
41 | protected data storage was disconnected during normal communication mode | ERROR_CODE_EKASA_ERROR_CHDU_DISCONNECTED |
42 | attempt to synchronize between PPEKK and protected data storage, when it is not possible | ERROR_CODE_EKASA_SYNCHRONIZE_ERROR |
43 | communication error with protected data storage | ERROR_CODE_EKASA_ERROR_CHDU_COMMUNICATION |
44 | protected data storage exceeded the timeout to perform the operation | ERROR_CODE_EKASA_ERROR_CHDU_OPERATION_TIMEOUT |
45 | protected data storage upgrade error | ERROR_CODE_EKASA_ERROR_UPGRADE_CHDU |
46 | PPEKK does not have anything to repair, even though you request a repair receipt | ERROR_CODE_EKASA_ERROR_PPEKK_NOTHING_TO_CORRECT |
47 | if the earlier receipt creation date is used than it is allowed | ERROR_CODE_EKASA_ERROR_BAD_CREATION_DATE |
48 | the parameter to correct the entry is incorrect | ERROR_CODE_EKASA_ERROR_BAD_CORRECTION_PARAMETER |
49 | incorrect identification string | ERROR_CODE_EKASA_ERROR_BAD_INIT_STRING |
50 | at least one item | ERROR_CODE_EKASA_ERROR_ITEM_REQUIRED |
51 | time zone error | ERROR_CODE_EKASA_ERROR_TIMEZONE |
52 | one of the command parameters is incorrect | ERROR_CODE_EKASA_ERROR_BAD_PARAMETER_VALUE |
53 | error saving the config file, performed rollback | |
54 | wrong VAT value | |
55 | print of receipt not finished, printing error, only foreKasa F20 |
Error codes from FS server (the last parameter of the get B51)
Code | Description |
|---|---|
-2 | Incorrect input values. |
-10 | Error in data report signature. |
-12 | Incorrect certificate format. |
-100 | Incorrect PKP value. |
-101 | TIN in data report does not match TIN from the certificate. |
-102 | ORP code in data report does not match ORP code from the certificate. |
-103 | The date and time of receipt execution is later than the date and time of processing. |
-104 | The date and time of receipt creation is later than the date and time of processing. |
-105 | The date and time of receipt creation is earlier than the date and time of processing. |
-106 | The date and time of receipt execution is earlier than the date and time of system startup. |
-107 | The date and time of receipt creation is earlier than the date and time of system startup. |
-108 | The date and time of location data creation is later than the date and time of processing. |
-109 | The date and time of location data creation is earlier than the date and time of processing. |
-110 | The date and time of location data creation is later than the date and time of system startup. |
-111 | Incorrect value of OKP. |
-112 | Invoice number must be filled in for document type: Invoice payment. |
-113 | VAT breakdown may not be filled out for document type: Invoice payment, Deposit, Withdrawal. |
-114 | Document type: Invoice payment, Deposit, Withdrawal must not contain items. |
-115 | Invoice number must not be filled in for receipt type: Receipt, Invalid receipt, Deposit, Withdrawal. |
-116 | Receipt type: Receipt, Invalid receipt must contain items. |
-117 | For item type: Returned, Corrective the receipt reference number must be filled in, to which the return, repair applies. |
-118 | For item type: Positive, Returned packaging, Discount, Deducted deposit the receipt reference number must not be filled in. |
-119 | VAT breakdown must be filled in for receipt type: Receipt, Invalid receipt. |
-120 | Basic rate tax amount and Base of basic tax rate must both be filled in or neither. |
-121 | Amount of reduced rate tax and Base of reduced tax rate must both be filled in or neither. |
-122 | The buyer ID and the buyer Type ID must both be filled in or neither. |
-123 | The buyer ID and the buyer Type ID must not be filled in for receipt type: Invalid receipt, Deposit, Withdrawal. |
-124 | Paragon number is mandatory when registering the paragon. |
-125 | Paragon number can be entered only when registering the paragon. |
-126 | It is not possible to register the paragon for receipt type: Invalid receipt, Deposit, Withdrawal. |
-127 | Item type: Positive cannot have a negative value. |
-128 | Item type: Returned packaging, Returned, Discount, Deducted deposit, Voucher exchange cannot have positive value. |
-129 | The merchant ID and the merchant Type ID must both be filled in or neither. |
-130 | For tax assignment: 20, 10 must not be filled in Word information. |
-131 | For item type: Positive, Returned packaging, Returned, Discount, Deducted deposit, a Single-purpose voucher number must not be filled in. |
-132 | Incorrect time zone. |
-8 | This version of integration interface is no longer supported. |
-13 | Certificate used is not valid. |